Refine your search:

I just set up the PDF server on my OpenSuse 11.1 host. I have an enterprise license installed, installed Xvfb, etc. The PDF gets generated and mailed; I can see the outline of my view and the processing time in the logs shows that it ran through all the searches, but I can't see any of the graphs.

Here's the python.log output from the PDF Server:

python.log:2011-07-27 12:45:03,087 INFO pdfhandler:532 - Generated pdf file.  bytes=153161 time=44.30
python.log:2011-07-27 12:45:03,087 INFO Generated pdf file.  bytes=153161 time=44.30
python.log:2011-07-27 12:45:03,143 INFO Generated PDF for email
python.log:2011-07-27 12:45:16,795 INFO sendemail opening PDF request to appserver at http://MyHost:8000/en-US/report/
python.log:2011-07-27 12:45:17,135 INFO pdfhandler:550 - Starting PDF App Renderer Version 1.2-2
python.log:2011-07-27 12:45:17,135 INFO Starting PDF App Renderer Version 1.2-2
python.log:2011-07-27 12:45:17,155 WARNING      pdfhandler:364 - body=Splunk;4.2;4.2
python.log:2011-07-27 12:45:17,155 WARNING      pdfhandler:365 - entries=['Splunk', '4.2', '4.2']
python.log:2011-07-27 12:45:17,167 WARNING      pdfhandler:461 - Restricting Firefox to following hosts only: *:53 10.8.240.131
python.log:2011-07-27 12:45:17,167 INFO pdfhandler:466 - Executing /opt/splunk/etc/apps/pdfserver/bin/firefox-x86_64/firefox -print http://MyHost:8000/app/MyApp/MyView -printmode pdf -printfile /tmp/tmpZUVCof -title Splunk Alert: MyView -orientation portrait -paperwidth 216 -paperheight 279 -mode splunk -timeout 180 -windowsize 1200x768 -footer_right Generated by Splunk at &D -cookie session_id_8000=8f142126d698f68330ec4bf269ba22aae6338e83
python.log:2011-07-27 12:45:17,167 INFO Executing /opt/splunk/etc/apps/pdfserver/bin/firefox-x86_64/firefox -print http://MyHost:8000/app/MyApp/MyView -printmode pdf -printfile /tmp/tmpZUVCof -title Splunk Alert: MyView -orientation portrait -paperwidth 216 -paperheight 279 -mode splunk -timeout 180 -windowsize 1200x768 -footer_right Generated by Splunk at &D -cookie session_id_8000=8f142126d698f68330ec4bf269ba22aae6338e83

I'm running Splunk 4.2, build 96430.

Does anyone have any suggestions for how I can resolve or troubleshoot this issue?

asked 27 Jul '11, 10:03

David's gravatar image

David
2.5k3327
accept rate: 46%

Be the first one to answer this question!
toggle preview

Follow this question

Log In to enable email subscriptions

RSS:

Answers

Answers + Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: 27 Jul '11, 10:03

Seen: 580 times

Last updated: 27 Jul '11, 10:03

Copyright © 2005-2014 Splunk Inc. All rights reserved.